ProMods The Great Steppe 1.0.1 Legacy

  • Sale
  • Regular price 33.69TL


THIS MOD MUST BE LOADED WITH A LOWER PRIORITY THAN THE MAIN PROMODS PACK


* IF YOU ARE USING THIS MOD TOGETHER WITH PROMODS YOU CAN RUN IT AS IS.
* IF YOU ARE USING THIS MOD WITHOUT PROMODS YOU WILL REQUIRE THE FLD PREFAB PACK;
https://forum.scssoft.com/viewtopic.php?t=285021

MOD DESCRIPTION:
This is a service update of the mod for game version 1.47

New content:

NEW IN 1.0.1:
        - Critical bug fixes versus 1.0.0

Important: Our mod has been designed for the 1.47 patch. If it works on other patches can be found here: https://www.promods.net/compat.php

Other mods are often not compatible with this mod. Ask the developers of these mods for more details or research our forums.
It should not be necessary to start a new profile, existing SCS profiles will automatically get updated, your current mission interrupted and your truck moved back to its home garage.

Compatible ETS 2 versions:
Our mod has been tested on v1.47 IT WON'T WORK WITH OLDER VERSIONS!

Customer Reviews

No reviews yet Write a review